一句代码禁用Gutenberg(古腾堡) 编辑器

[mark_a]WordPress 5.0正式版发布以后,新的Gutenberg 编辑器(在WP5.0中准确地说应该叫block editor编辑器)给众多用户带来困惑,很简单的文字编辑操作,变得繁琐复杂,虽然用户对这个编辑器意见很大,但WP开发团队强推也没有办法。文章转载于-知更鸟[/mark_a]

可以通过安装Classic Editor或者Disable Gutenberg插件,切换回经典的编辑器。

其实之前经典的Classic Editor编辑器代码,在WordPress 5.0并没有被删除,上述插件也只是个切换开关而已。

关键代码就一句:

add_filter('use_block_editor_for_post', '__return_false');

将代码添加到当前主题函数模板functions.php中,即可切换回之前的编辑器,根本不需要那些插件。

当然你想有更多的选择性,可以安装上述插件。

后台禁用block editor编辑器后,前端还是会加载相关的的样式文件,还需要加上一句:

remove_action( 'wp_enqueue_scripts', 'wp_common_block_scripts_and_styles' );

禁止前端加载样式文件。

Classic Editor编辑器代码据WP官方称会延续集成到2021年才会从程序中彻底删除,但大家也不用担心,到时会有全套的Classic Editor编辑器插件让你选择。

另外,完整中文版估计遥遥无期,目前5.0版完全可以用之前的语言文件,除了新编辑器没有汉化,其它没有影响。

看了一下其它语言的WP程序,目前都没有本地化编辑器。

给TA买糖
共{{data.count}}人
人已赞赏
wordpress教程

禁用 WordPress 更新检测和自动更新功能

2018-12-6 9:08:31

wordpress教程

wordpress实现简单的动态分离

2018-12-11 23:47:13

3 条回复 A文章作者 M管理员
  1. 感谢分享

  2. 可用。得折腾,老了就折腾不动了。

  3. 还是不折腾了,等WP5.0顺手了,我在升级

个人中心
购物车
优惠劵
今日签到
有新私信 私信列表
搜索